Back to overview
Degraded

Mastodon Service Degraded

Jan 04 at 09:47am MST

Resolved
Jan 05 at 02:15am MST

We've upgraded the postgresql database to a $240/mo VM. This has solved today's latency. We will continue to monitor the instance but believe we're in good shape to handle tomorrow's traffic.

Updated
Jan 04 at 11:00pm MST

Latency remains around two hours however good news: queues are starting to recover due to some actions taken.

Actions taken:
- pg_repack on the database (took 45 minutes!)
- pulled fresh code from the git repository and recompiled both the web and job processing servers.

Updated
Jan 04 at 06:55pm MST

We are experiencing latency of up to two hours. You may also find that at times third-party apps may not be able to connect to the instance. This is expected as we try to get queues back to a manageable level.

We recognize that this is frustrating and are working from every angle we can to get this under control.

Created
Jan 04 at 09:47am MST

We're aware that mstdn.ca is running slow. We thank you for your patience.

Nous savons que mstdn.ca fonctionne au ralenti. Merci pour votre patience.