Back to overview
Degraded

Delayed notifications

Jul 30 at 11:32pm MDT
Affected services
mstdn.ca
Streaming API

Resolved
Jul 31 at 10:14pm MDT

We identified the root cause of the problem and were able to remove the problematic records. This has cleared up the notification delay.

Updated
Jul 31 at 02:10pm MDT

Notifications are still delayed by about one hour, which is significantly better than where we were last night.

We'll continue to monitor the situation.

Created
Jul 30 at 11:32pm MDT

You may have noticed that you aren't getting timely notifications from mstdn.ca today.

A third-party push notification service that many popular apps use went down yesterday and caused our notification queues to pile up.

Additional resources have been dispatched to work to catch up on the notification queues.